Delayed Policy Changes in Hong Kong

Resolved

We have resolved this incident
Posted Aug 07, 2025 - 20:38 UTC

Investigating

We are investigating an issue that is causing policy changes originating from our Hong Kong data center to have a delayed propagation time of over 50 minutes. We will update this status with more information as it becomes available.
Posted Aug 07, 2025 - 20:09 UTC
This incident affected: Asia Pacific (Hong Kong) (DNS, Web Security).