For EU customers Dashboard Activity Search failed.

Resolved

The issue with Dashboard Activity Search for EU customers has been resolved.

The service is now operating normally.
Posted Oct 23, 2025 - 12:50 UTC

Investigating

We’re currently experiencing issues for EU customers with the Dashboard activity search function displaying "Unable to retrieve information."

The issue is under investigation.

As current workaround customers need to go "Monitor" --> "Activity Search" and select the type of logs any except of "Firewall" and "All"

We will provide updates as soon as more information is available.
Posted Oct 23, 2025 - 12:36 UTC
This incident affected: Global (Dashboard).