Issue with loading user identities and groups

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 00:30 UTC

Investigating

We are currently investigating an issue where the user identities and groups are not loading in the dashboard. We are currently working on the issue and will update as soon as we have an update.
Posted Aug 21, 2025 - 22:42 UTC
This incident affected: Global (Identity).