Slow DNS response when connecting to Mumbai DC
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 17:46 UTC
Identified
We are investigating an issue with slow responses when DNS requests are being sent to Mumbai datacenter . We will provide updates periodically and when new information is available.
Posted Nov 11, 2024 - 11:17 UTC
This incident affected: DNS (Asia).