Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 03, 2025 - 15:00 UTC
Scheduled
Please be advised that our Jeddah Data Centre will be taken out of rotation for scheduled maintenance starting on November 3rd, 2025
During this period, all traffic will be automatically redirected to the closest available data center to ensure continued service availability. Please ensure your redundant tunnel to the secondary Data Centre is functional to maintain high availability.
We appreciate your understanding and are committed to minimizing any potential impact. If you have any questions or concerns, please contact our support team.
Posted Oct 31, 2025 - 07:01 UTC
This scheduled maintenance affects: Saudi Arabia (DNS, Experience Insights (LA), Network Tunnel Groups (LA), Remote Access VPN (LA), Remote Browser Isolation (LA), Reserved IP (LA), Resource Connector (LA), Web Security (LA), Zero Trust Access (LA)).