Issues with dashboard functions: users/groups listing and policies modifications

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 13:21 UTC

Investigating

We are currently investigating an issue that is affecting certain functions on the dashboard, such as editing policies and loading the list of users and groups, which may take longer than expected.

We will provide updates periodically and as new information becomes available.
Posted Jun 30, 2025 - 12:22 UTC
This incident affected: Global (Dashboard).