Onboarding Failures in Cisco Secure Access

Resolved

The third-party vendor has resolved the certificate provisioning issue, and onboarding processes are now working as expected.
Posted Apr 29, 2026 - 21:54 UTC

Monitoring

The third-party vendor has remediated the certificate provisioning issue. We are now seeing onboarding return to normal patterns.
Posted Apr 29, 2026 - 21:24 UTC

Update

We are actively working with third-party vendor to remediate the certificate provisioning issue. We will continue to provide updates as additional information becomes available.
Posted Apr 29, 2026 - 20:53 UTC

Investigating

We are currently investigating an issue impacting Cisco Secure Access onboarding.
Due to a third-party provider outage affecting certificate issuance, onboarding of new organizations may fail or become stuck.
Existing customers and active services remain unaffected and continue to operate normally.
Our engineering team is actively working with the provider to restore normal onboarding. We will provide updates as more information becomes available.
Posted Apr 29, 2026 - 18:53 UTC
This incident affected: Global (API).