[Cisco Secure Access]- Firewall Configuration Update Performance Degradation-Mumbai, Middle East and Saudi Arabia

Resolved

The issue has been resolved.

We apologize for any inconvenience caused and thank you for your patience.
Posted Feb 21, 2026 - 05:34 UTC

Monitoring

We are no longer seeing delays in firewall policy changes in the Mumbai, Middle East, and Saudi Arabia regions, and we continue to monitor the situation closely.
Posted Feb 21, 2026 - 05:24 UTC

Update

Our engineering team is actively investigating the issue.
We will provide another update as soon as any new information becomes available.
Posted Feb 21, 2026 - 04:23 UTC

Investigating

We are currently encountering delays in the propagation of firewall policy changes in the Mumbai, Middle East, and Saudi Arabia regions.

Our engineering team is actively working to confirm the impact, identify the root cause, and implement a resolution. We are committed to restoring full service as quickly as possible. Updates and additional details will be provided as new information becomes available. We appreciate your patience and understanding during this time
Posted Feb 21, 2026 - 03:00 UTC
This incident affected: India (West) (Policy Enforcement), Middle East (UAE) (Policy Enforcement), and Saudi Arabia (Policy Enforcement).