Slowness with dashboard functions: users/groups listing and policies modifications

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 11:27 UTC

Investigating

Some customers may have experienced a slowness when loading the policies and identities section of the dashboard around 10:30 UTC on Thu 03-Jul-2025. This is now resolved and under monitoring.
Posted Jul 03, 2025 - 11:24 UTC
This incident affected: Global (Dashboard).