Cisco Secure Access - Connectivity and Timeout Issues - London

Resolved

We are pleased to confirm that the connectivity and capacity issues in the London region have been fully resolved. All services are now operating normally, and customers should no longer experience timeouts or performance degradation.

Thank you for your patience and understanding during this incident. If you have any questions or need assistance, please contact our support team.
Posted Apr 01, 2026 - 10:46 UTC

Identified

We are actively working to mitigate the current capacity constraints affecting connectivity in the London region. As mitigation steps are implemented, customers should begin to see improvements with connectivity and fewer timeouts. We will continue to monitor progress and provide updates as needed.
Posted Apr 01, 2026 - 10:28 UTC

Investigating

We are currently investigating reports of timeouts affecting services in the London data center. Some users may experience delays or interruptions in their requests.

Our team is actively working to identify the cause and restore full service as quickly as possible. Updates will be provided here as more information becomes available.

Thank you for your patience and understanding.
Posted Apr 01, 2026 - 09:11 UTC
This incident affected: United Kingdom (Web Security).