Cisco Secure Access: Dashboard Components Not Loading for Customers – Global

Resolved

This incident has been resolved. Engineering has restored Cisco Umbrella and Cisco Secure Access dashboard functionality, including impacted policy and administrative workflows.

We will continue monitoring service health and completing follow-up analysis. No further customer impact is expected at this time.
Posted Jun 04, 2026 - 00:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 03, 2026 - 23:36 UTC

Update

Our engineering teams are actively investigating reports of degraded performance affecting the Cisco Umbrella and Secure Connect dashboards.

While initial mitigation efforts—including disabling the ZTNA App Portal and scaling the Unified Policy (UP) service—have been implemented, we are continuing to observe inconsistent performance. Some dashboard elements may fail to load or experience significant latency.

The Unified Policy team is currently conducting a deep-dive investigation to identify the underlying cause and restore full system stability. We apologize for the continued disruption and appreciate your patience as we work toward a resolution.
We will provide further updates as more information becomes available.
Posted Jun 03, 2026 - 23:13 UTC

Update

As part of ongoing mitigation efforts, the ZTA App Portal service has been temporarily disabled as a precautionary measure to address the elevated volume of requests contributing to the current degradation. Engineering teams have confirmed this action and are actively monitoring systems to validate the expected reduction in traffic and confirm service stabilization. Updates will be provided as the situation progresses.
Posted Jun 03, 2026 - 22:04 UTC

Update

Engineering teams are actively working toward a fix. Updates will be provided as progress is made.
Posted Jun 03, 2026 - 21:35 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 03, 2026 - 21:27 UTC

Identified

Engineering has identified the source of the issue and is actively working on a resolution.

We are committed to restoring service as quickly as possible and will share progress updates as the situation evolves. Thank you for your patience.
Posted Jun 03, 2026 - 20:46 UTC

Investigating

We are currently investigating a potential issue affecting Dashboard components, which may impact customers connecting to the Global service.

Our engineering team is actively working to confirm the extent of the impact, identify the root cause, and implement a resolution. We will provide updates and additional details as new information becomes available.
Posted Jun 03, 2026 - 20:02 UTC
This incident affected: Global (Dashboard).