[Cisco Secure Access]-Dashboard-Query Volume Display Degradation

Identified

We have identified the issue impacting the Investigate dashboard.
DNS resolution, traffic handling, and policy enforcement remain fully operational.
The team is preparing remediation steps and will continue monitoring the system.
Posted Feb 27, 2026 - 18:18 UTC

Investigating

We are currently investigating an issue impacting one feature within the Investigate dashboard, specifically the DNS query volume. This affects the visibility of query volume data in the UI.
All other Umbrella services, including DNS resolution, traffic handling, and policy enforcement, remain fully operational.

Our team is actively working to restore normal data processing for the affected dashboard feature and will provide updates as they become available.
Posted Feb 27, 2026 - 18:16 UTC
This incident affects: Global (Dashboard).