Jeddah Data Center Investigation

Resolved

This incident has been resolved.
Posted May 13, 2025 - 15:57 UTC

Investigating

We are investigating an issue impacting the Jeddah data center for Cisco Secure Access, we will provide further updates as more information becomes available.
Posted May 13, 2025 - 15:24 UTC
This incident affected: Saudi Arabia (Policy Enforcement, Remote Access VPN (LA), Resource Connector (LA)).