Intermittent latency increase on some DNS resolution requests

Resolved

The incident has been resolved as of approximately 2025-11-29 09:33 UTC.
Posted Nov 29, 2025 - 10:09 UTC

Investigating

We are currently investigating an issue involving an intermittent latency increase on some DNS resolution requests.
Posted Nov 29, 2025 - 08:00 UTC
This incident affected: US (Pacific Northwest) (DNS), US (Midwest) (DNS), US (California) (DNS), and US (Virginia) (DNS).