DNS Resolution Issues at Brazil Data Center

Resolved

The root cause of this issue has been remediated and service is now fully restored.
Posted Jul 11, 2025 - 02:35 UTC

Investigating

We are currently investigating an issue affecting DNS resolution when using 208.67.222.222 at our Brazil data center. Customers using this DNS server may experience increased latency and connection retries. To minimize impact, we recommend configuring your DNS settings to use 208.67.220.220, 208.67.222.220, or 208.67.220.222 instead of 208.67.222.222. We will provide further updates as soon as more information becomes available.
Posted Jul 10, 2025 - 22:43 UTC
This incident affected: Brazil (DNS).